Shock Fitting advice, ASAP Please....

· 6 · 102

0 Members and 1 Guest are viewing this topic.

*

Mikey

  • ***
  • Posts: 120
Shock Fitting advice, ASAP Please....
« on: April 02, 2021, 08:43:36 PM »
Hi All,

This has been a bain of my life for a while, but could really do with a 'quick fix' for this.
I'm fitting new front shock and springs to my 110. A Job I've done before, front and back, plenty of times.

It often seems to be an issue that the lower studs on the shocks are not quite long enough to get a bite on the nut to start squashing the bushes. I don't have the 'welded in place' bush cups fitted, just using the cups and bushes that come with the shocks.

All proper parts for the job, and as I say, this has been an issue before for me.

Any advice appreciated..... I need the Landy running by Tuesday....

Mike
Mikey.
1985 110 CSW, 300Tdi fitted.
1993 Classic LSE, V8 LPG.

*

Bruce

  • *****
  • Posts: 25
  • Name: Daniel Bruce McPhee
Re: Shock Fitting advice, ASAP Please....
« Reply #1 on: April 02, 2021, 10:51:16 PM »
Hi
I have had issues like this before.
I think I used D clamps to squash the two cups together with the bush in the middle.
Or a couple of vice grips might also work.
It was some years ago so not sure how I managed.

Good Luck.

Bruce.

*

Mikey

  • ***
  • Posts: 120
Re: Shock Fitting advice, ASAP Please....
« Reply #2 on: April 02, 2021, 11:13:28 PM »
Hi Bruce,

Yeah, thought of that sort of thing but can't really work out how to get the clamps in and about it.... Going to try with some other unused bushes I have in the shed and see if any are a wee bit thinner than the new ones I have....

Cheers

Mike
Mikey.
1985 110 CSW, 300Tdi fitted.
1993 Classic LSE, V8 LPG.

*

rangerovering

  • *******
  • Posts: 1270
Re: Shock Fitting advice, ASAP Please....
« Reply #3 on: April 05, 2021, 08:49:53 AM »
Are you using polybushes? I have ground them down before because of the same problem.
Steve




*

Mikey

  • ***
  • Posts: 120
Re: Shock Fitting advice, ASAP Please....
« Reply #4 on: April 05, 2021, 10:58:07 AM »
Hey Steve,

Yes, it always seems to be the problem with ploybushes.
And yes, I've also taken a couple of mm off them which gives just enough to get a start on the thread which I can't see makes any practical difference. Anyhoo, done now!

Cheers.
Mikey.
1985 110 CSW, 300Tdi fitted.
1993 Classic LSE, V8 LPG.

Re: Shock Fitting advice, ASAP Please....
« Reply #5 on: April 05, 2021, 06:48:52 PM »
Try jacking the axle up to squash the bushes

That's should let you get the nut on